Skip to content

Latest commit

 

History

History
139 lines (128 loc) · 4.37 KB

hdu1253.MD

File metadata and controls

139 lines (128 loc) · 4.37 KB

日期 2021 / 10 / 29

题目

[题目链接]https://acm.dingbacode.com/showproblem.php?pid=1253 截屏2021-10-29 17 58 12

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 55557 Accepted Submission(s): 19048

Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

截屏2021-10-29 17 59 23

Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1

3 3 4 20

0 1 1 1

0 0 1 1

0 1 1 1

1 1 1 1

1 0 0 1

0 1 1 1

0 0 0 0

0 1 1 0

0 1 1 0

Sample Output

11

解题思路

这个题目是一个三维的bfs,题目要求就是在规定时间内能不能走出迷宫,这里得用一个三维map记录地图,并且向六个方向遍历 我在写的时候忘记cpp(b.x >= 0 && b.x < A && b.y >= 0 && b.y < B && b.z >= 0 && b.z < C && map1[b.x][b.y][b.z] == 0) 这个判断代码是得放在遍历方向之前还是之后,后面想了一下你每次遍历出一个方向的点得经过判断才能放入队列中所以是后者,这里我本来还想用一个vis数组判断每个点是否走过 后面发现其实你把每次走过的点设置为墙就可以了,这样就节约了空间的开销.

代码演示

#include <bits/stdc++.h>

#define INF 0x7fffffff
#define rep(x, y, z) for (int x = y; x <= z; x++)
#define dec(x, y, z) for (int x = y; x >= z; x--)
#define format(a) memset (a, 0, sizeof(a))
#define swap(a, b) (a ^= b ^= a ^= b)
#define ll long long int
#define ull unsigned long long int 
#define uint unsigned int
const int maxn = 1e6 + 10;
using namespace std;

inline int read() {

int A, B, C, T;
struct node {
  int x, y, z;
  int step;
};

int map1[52][52][52];
int vis[52][52][52];
int dir[][3] = { {0, 0 ,1}, {1, 0, 0}, {-1, 0, 0}, {0, 1, 0}, {0, -1, 0}, {0, 0, -1}};

int bfs() {
  node a, b;
  queue<node> q;
  a.x = 0;
  a.y = 0;
  a.z = 0;
  a.step = 0;
  q.push(a);
  while (!q.empty()) {
    a = q.front();
    q.pop();
    if (a.x == A - 1 && a.y == B - 1 && a.z == C - 1 && a.step <= T) {
      return a.step;
    }
    for (int i = 0; i < 6; i++) {
      b.x = a.x + dir[i][0];
      b.y = a.y + dir[i][1];
      b.z = a.z + dir[i][2];
      b.step = a.step + 1;
      if (b.x >= 0 && b.x < A && b.y >= 0 && b.y < B && b.z >= 0 && b.z < C && map1[b.x][b.y][b.z] == 0) {
        map1[b.x][b.y][b.z] = 1;
	q.push(b);
      }
    }
  }
  return -1;
}

int main(int argc, char *argv[]) {
  ios_base::sync_with_stdio(false);
  cin.tie(nullptr);
  int k;
  cin >> k;
  while (k--) {
    cin >> A >> B >> C >> T;
    format(vis);  
    for (int i = 0; i < A; i++) {
      for (int j = 0; j < B; j++) {
        for (int k = 0; k < C; k++) {
	  cin >> map1[i][j][k];
        }
      }
    }
    cout << bfs() << endl;
  }
  return 0;
}